Feedback Performance vServer #2

Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge
Erweiterte Suche  

Autor Thema: Feedback Performance vServer #2  (Gelesen 37901 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3414
    • http://www.euserv.de
Feedback Performance vServer #2
« am: 02.Januar 2009, 20:54:51 »

Thread #2 zum Feedback "Performance vServer"

Hallo,

EUserv hat auf Basis der Diskussion in http://forum.euserv.de/index.php?topic=1964.0 heute kleinere Änderungen an den Konfigurationen der Hostnodes und der VE's eingespielt, die zu einer Verbesserung der Performance führen sollen.

Wir freuen uns auf reges Feedback in diesem Thread.

viele Grüße,
Thomas

« Letzte Änderung: 03.Januar 2009, 10:05:03 von Forum-Support2 »
Gespeichert


viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

riclie

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 55
Re: Feedback Performance vServer #2
« Antwort #1 am: 02.Januar 2009, 21:22:30 »

Thread #2 zum Feedback "Performance vServer"

Hallo,

EUserv hat auf Basis der Diskussion in http://forum.euserv.de/index.php?topic=1964.0 heute kleinere Änderungen an den Konfigurationen der Hostnodes und der VE's eingespielt, die zu einer Verbesserung der Performance führen sollen.

Wir freuen uns auf reges Feedback in diesem Thread.

viele Grüße,
Thomas




ok dann bin ich wohl hier genau richtig also seit huete 21:14 kam ein alert bei mir hoch das der ssh dienst nciht mehr erreichbar sei danach war der ganze hostz nciht mehr erreichbar und liess sich nur ser müsselig langsam rebooten. ca 1h nach impact des systems kam der host wieder hoch und dann kamm folgende meldung beim versuch sich via ssh zu connecten.

-bash: error while loading shared libraries: libncurses.so.5: cannot open shared object file: Error 23
Connection to xxx-xxx-xxx-xxx.blue.kundencontroller.de closed.

das open file problem im image ist also warshceinlich eine zu niedrige ulimit.conf eintrag enthalten oder die standard einstellung von 1024 ulimit wird in der /etc/security/ulimits.conf oder /et.pam.d/su bzw. /etc/pam.d/limits.conf configuriert. dies muss jenachdem was drafu lafuen sollte erhöht werden ansonsten ist dann ein server freeze festzustellen http noch errecihbar aber ssh eben nciht bz. eben gar nciht mehr erreichbar. davohn auszugehen ist das der sshd die openfiles erzeugt(vermudung). Die sache ist die ein reboot via kundencenter schein hier aber nciht zu helfen.

Was kann man ncoh tun die conf erhögen dazu müsste man aber auf die maschiene kommen.

im /varlog/message file ist zu dem wenn man drafu ist vor so einem freeze immer mal eine meldung der art "max count rlimits/ open files 1024 with gid 0 pid xxxx reached" zu finden dies deutet darafu hion das soetwas befor steht. und sollte erst genommen werden. Ansonsten siehts dann so aus wie bei mir jetzt.

Ichz hatte diese probleme nur bis heute bei richtigen Root-Servern mit SLES9/ SLES10 und IBM Hardware.

Gruß und Danke für hilfe stellungen oder andere erkenntnisse zum Thema Vserver Linux und open files limits.
Gespeichert
-------------------------------
Interpunktion und Orthographie meiner Schreibweise ist frei erfunden.
Eine Übereinstimmung mit aktuellen oder ehemaligen Regeln wäre rein zufällig und ist nicht beabsichtig

Thorror

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 14
Re: Feedback Performance vServer #2
« Antwort #2 am: 03.Januar 2009, 11:52:52 »

Gemäß cat /proc/user_beancounters stehen nur noch 1024 numfile zur Verfügung. So sieht das ganze nach einem frischen Neuinstall von Debian 4.0 mit SysCP aus. Und da laufen nur die Dienste ohne Last oder irgendwelche Operationen

numfile                       891                  925                 1024                 1024                    0

Meint ihr nicht, dass das ein bißchen arg nach unten geschraubt wurde?

Denn das ganze führt beim ersten Update zu folgendem

(Lese Datenbank ... 14324 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereiten zum Ersetzen von perl-modules 5.8.8-7etch3 (durch .../perl-modules_5.8.8-7etch6_all.deb) ...
Entpacke Ersatz für perl-modules ...
Vorbereiten zum Ersetzen von libc6 2.3.6.ds1-13etch7 (durch .../libc6_2.3.6.ds1-13etch8_amd64.deb) ...
Entpacke Ersatz für libc6 ...
Richte libc6 ein (2.3.6.ds1-13etch8) ...
xargs: /bin/echo: Too many open files in system
xargs: /bin/echo: Too many open files in system
/etc/init.d/glibc.sh: line 17: /bin/sed: Too many open files in system
/etc/init.d/glibc.sh: line 18: /bin/sed: Too many open files in system
/etc/init.d/glibc.sh: line 17: /bin/sed: Too many open files in system
/etc/init.d/glibc.sh: line 18: /bin/sed: Too many open files in system


Und das ist nur ein Auszug aus den Fehlern.So ist das wohl nicht zu gebrauchen
« Letzte Änderung: 03.Januar 2009, 12:04:06 von Thorror »
Gespeichert

voodoo44

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 37
Re: Feedback Performance vServer #2
« Antwort #3 am: 03.Januar 2009, 13:59:34 »

Um es nochmal anzusprechen:
Das Problem mit dem hohen "Ping" auf der Shell ist immer noch vorhanden, zumindest bei mir.

Manchmal läufts einwandfrei, manchmal warte ich 4-5 Sekunden, dass sich überhaupt irgendwas tut, wenn ich einen Befehl eintippe.

Evtl. sollte man da nochmal nachschauen, woran es liegen könnte, dass solche Probleme auftauchen. Denn ein vServer, auf dem nichtmal die Konsole richtig rund läuft ... ;)

Ansonsten kann ich zumindest sagen, dass sich die diversen Images, die ich bisher durchgetestet habe problemlos installieren ließen, ich jedoch auf allen bisher die gleichen Probleme mit der Shell und der entsprechenden Verzögerung hatte.

/EDIT:
Nach einem Router-Restart sehe ich gerade, dass das ganze nun doch scheinbar WESENTLICH flüssiger läuft, kleinere Verzögerungen hat man noch, aber die sind im Grunde fast komplett zu vernachlässigen.
« Letzte Änderung: 03.Januar 2009, 14:01:22 von voodoo44 »
Gespeichert

djrick

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 5
Re: Feedback Performance vServer #2
« Antwort #4 am: 03.Januar 2009, 14:53:09 »

Hallo,
kleinere Änderungen an den Konfigurationen der Hostnodes und der VE's eingespielt
Wäre noch schön zu erfahren WELCHE Änderungen denn vorgenommen wurde :)
Gespeichert

riclie

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 55
Re: Feedback Performance vServer #2
« Antwort #5 am: 03.Januar 2009, 15:17:30 »

super kaum 5 min auf der kiste und mal webmin gestartet und wollte den apache durch starten mit apache2ctl graceful dann kam shcon wieder zu viele open files

81-89-97-235:~#  cat /proc/user_beancounters
Version: 2.5
       uid  resource                     held              maxheld              barrier                limit              failcnt
    10172:  kmemsize                  6946037              7377766             31875611             35028144                    0
            lockedpages                     0                    0                 2059                 2059                    0
            privvmpages                 86663                89690               131072               262144                    0
            shmpages                     8125                 8141                50000                50000                    0
            dummy                           0                    0                    0                    0                    0
            numproc                        54                   58                  300                  300                    0
            physpages                   10972                11440                    0           2147483647                    0
            vmguarpages                     0                    0               131072           2147483647                    0
            oomguarpages                11044                11512               131072           2147483647                    0
            numtcpsock                     13                   18                  200                  200                    0
            numflock                        3                    9                   50                   50                    0
            numpty                          1                    1                  128                  128                    0
            numsiginfo                      0                    4                 1024                 1024                    0
            tcpsndbuf                  230544               230544              6584420              9402468                    0
            tcprcvbuf                  212992                    0              6584420              9402468                    0
            othersockbuf                28592                31968              4923119              9133807                    0
            dgramrcvbuf                     0                 8736              4923119              4923119                    0
            numothersock                   20                   22                  200                  200                    0
            dcachesize                 291090               304236              6155930              6340608                    0
            numfile                      1001                 1024                 1024                 1024                 1116
            dummy                           0                    0                    0                    0                    0
            dummy                           0                    0                    0                    0                    0
            dummy                           0                    0                    0                    0                    0
            numiptent                      10                   10           2147483647           2147483647                    0
81-89-97-235:~#

so siehts bei mir aus. ging bis gestern abend 2.1.2009 21:14 gut ab dann nur ncoh probleme und kein nutzen mehr möglich man kann keine anwendung drafu starten.

egal was an der performance gedereht wurde bloß schnell wieder zurück drehen denn so wies jetzt geht gehts gar nicht.

Gruß Rico
« Letzte Änderung: 03.Januar 2009, 15:32:56 von riclie »
Gespeichert
-------------------------------
Interpunktion und Orthographie meiner Schreibweise ist frei erfunden.
Eine Übereinstimmung mit aktuellen oder ehemaligen Regeln wäre rein zufällig und ist nicht beabsichtig

Thorror

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 14
Re: Feedback Performance vServer #2
« Antwort #6 am: 03.Januar 2009, 17:36:36 »

numfile Limit wurde jetzt anscheinend von 1024 auf 4096 angehoben. Läuft wieder
Gespeichert

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3414
    • http://www.euserv.de
Re: Feedback Performance vServer #2
« Antwort #7 am: 03.Januar 2009, 17:58:40 »

Hallo,

die zu streng limitierten Filelimits wurden auf 2048 bzw. 4096 (je nach Hostnode) zum Testen erhöht,
das sollte ausreichend sein in dieser Ausstattungs-Variante. Einige VE könnten hängen und brauchen
wahrscheinlich einen Restart über den Kundencenter.

viele Grüße,
Thomas
« Letzte Änderung: 03.Januar 2009, 22:59:10 von Forum-Support2 »
Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

dreamer

  • Gast
Re: Feedback Performance vServer #2
« Antwort #8 am: 04.Januar 2009, 11:25:35 »

Bisher ließ sich meinerseits keine Änderung feststellen. Die SSH-Eingaben brauchen immer noch lange, auch nachts. Von den aktuellen Verboten, gerade bzgl. der SETI-Clients und Konsorten, hatte ich mir doch eine Besserung versprochen. Aber ich werde noch ausführlichere Tests machen, ob sich nicht doch eine Tendenz zeigt. Der rkhunter-Test hat aber schon länger gedauert als vor der Umstellung.

Gruß

edit: Ich lese immer wieder was von schlechten Pings. Das kann ich hingegen nicht berichten, die Maschine antwortet ca. 5-10ms langsamer als z.B. heise.de auf ICMP-Echorequests.
« Letzte Änderung: 05.Januar 2009, 09:19:31 von dreamer »
Gespeichert

fipu

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 11
Re: Feedback Performance vServer #2
« Antwort #9 am: 05.Januar 2009, 21:18:13 »

Hier mein WHT Ergebnis:

TEST                                        BASELINE     RESULT      INDEX

Dhrystone 2 using register variables        376783.7        1.0        0.0
Double-Precision Whetstone                      83.1        0.0        0.0
Execl Throughput                               188.3        1.0        0.1
Pipe Throughput                             111814.6        1.0        0.0
Pipe-based Context Switching                 15448.6        1.0        0.0
Process Creation                               569.3        1.0        0.0
Shell Scripts (8 concurrent)                    44.8        1.0        0.2
System Call Overhead                        114433.5        1.0        0.0
                                                                 =========
     FINAL SCORE                                                       0.0


Und zum Vergleich hier das Ergebnis von meinem 9 Euro / Mon vServer:

TEST                                        BASELINE     RESULT      INDEX

Dhrystone 2 using register variables        376783.7  9826826.7      260.8
Double-Precision Whetstone                      83.1     1150.2      138.4
Execl Throughput                               188.3     4756.4      252.6
File Copy 1024 bufsize 2000 maxblocks         2672.0    89360.0      334.4
File Copy 256 bufsize 500 maxblocks           1077.0    31619.0      293.6
File Read 4096 bufsize 8000 maxblocks        15382.0   876130.0      569.6
Pipe Throughput                             111814.6   898896.8       80.4
Pipe-based Context Switching                 15448.6   277953.6      179.9
Process Creation                               569.3    14003.1      246.0
Shell Scripts (8 concurrent)                    44.8      918.8      205.1
System Call Overhead                        114433.5  1351477.6      118.1
                                                                 =========
     FINAL SCORE                                                     214.4


Habe den Test mehrmals wiederholt mit dem vServer von euServ und komme auf kein anderes Ergebnis.


Netzwerkspeed in verschiedene Netze ist ok (mehrere MB/s). Wobei ich dazu noch sagen muss dass ich keinen eigenen Server für den Test verwendet habe und daher nicht weiss ob 100 % der Bandbreite für meinen Test zur Verfügung stand. Es könnte also sein dass die vServer noch mehr schaffen.

Als Gameserver ist der vServer wie erwartet nicht geeignet. Für Dienste wie Teamspeak ist der vServer gut geeignet.
Gespeichert

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3414
    • http://www.euserv.de
Re: Feedback Performance vServer #2
« Antwort #10 am: 05.Januar 2009, 22:19:41 »

Hier mein WHT Ergebnis:

TEST                                        BASELINE     RESULT      INDEX
System Call Overhead                        114433.5        1.0        0.0
                                                                 =========
     FINAL SCORE                                                       0.0


Das ist ja ein sagenhaftes Ergebnis im negativen Sinne ;) Ich bitte um die IP,
damit ich mir das mal anschauen kann.

Danke und viele Grüße,
Thomas
Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

fipu

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 11
Re: Feedback Performance vServer #2
« Antwort #11 am: 06.Januar 2009, 17:43:44 »

Hallo Thomas,

Hier die IP-Adresse: 81.89.97.172
Gespeichert

dreamer

  • Gast
Re: Feedback Performance vServer #2
« Antwort #12 am: 09.Januar 2009, 23:35:41 »

Oh man, es wird immer schlimmer, auf meinem System läuft:

USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root         1  0.0  0.1   6120   540 ?        Ss   Jan01   0:00 init [2]
root      1511  0.0  0.5  36788  2752 ?        Rs   00:11   0:00 sshd: root@pts/0
root      1810  0.0  0.3  12928  2084 pts/0    Ss   00:12   0:00 -bash
root      7572  0.0  0.1  25840   668 ?        Ss   Jan01   0:00 /usr/sbin/sshd
root      8057  0.0  0.1   9856   988 pts/0    R+   00:27   0:00 ps aux
root     31953  0.0  0.1   3732   616 ?        Ss   Jan01   0:00 /sbin/syslogd
root     31981  0.0  0.1  11500   716 ?        Ss   Jan01   0:00 /usr/sbin/cron

und ich brauche über 5min um einen "ps aux" auszuführen? Und ich übertreibe hier nicht, es ist kein Arbeiten möglich! Nachts um halb eins??
Ich weiss, dass es ein kostenloser Test ist, aber so macht es weder Spaß noch Sinn das Teil zu testen.
Bitte verändert diesbzgl. etwas, so ist das einfach nur Zeitverschwendung mit warten...

Gruß dreamer

edit: 81-89-97-15:/ventrilo# time deluser ventrilo


real    6m37.424s
user    0m0.002s
sys     0m0.017s
und es kam, wie man sieht, noch nicht mal eine Statusausgabe. Befehl wurde per Strg+C abgebrochen, was auch ewig dauerte. Mal schauen, ob ein Reboot etwas ändert.

edit2: Keine Reboot-/Stop-Funktion innerhalb etwa einer Stunde
edit3: 10 Stunden später: Status des vServers
System-Status: running
letzter Check: 2009-01-10 00:07:11
Scheinbar funktioniert auch der Statuscheck nicht... könnte bitte jemand kurz erklären, was hier los ist? IP 81.89.97.15 - vServer wurde nicht rebootet/gestoppt seit heute Nacht und nun, beim SSH Login, bekomm ich einerseits kein Connection refused, aber auch keinen Timeout, also ist das Teil doch total überladen. Liege ich damit richtig??
« Letzte Änderung: 10.Januar 2009, 10:59:45 von dreamer »
Gespeichert

R. S.

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 11
Re: Feedback Performance vServer #2
« Antwort #13 am: 10.Januar 2009, 00:14:43 »

Also ich bin mit der Server Leistung eigenlich zufrieden. Für TS² reichts. Für mehr aber auch net.

Hier mal n paar infos von mir:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) D  CPU 2.66GHz
stepping        : 7
cpu MHz         : 1011.726
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall lm constant_tsc pni monitor ds_cpl tm2 cid cx16 xtpr lahf_lm
bogomips        : 5328.76
clflush size    : 64
cache_alignment : 128
address sizes   : 36 bits physical, 48 bits virtual
power management:

                     INDEX VALUES
TEST                                        BASELINE     RESULT      INDEX

Dhrystone 2 using register variables        376783.7  1141978.4       30.3
Double-Precision Whetstone                      83.1      605.8       72.9
Execl Throughput                               188.3      682.4       36.2
File Copy 1024 bufsize 2000 maxblocks         2672.0    20372.0       76.2
File Copy 256 bufsize 500 maxblocks           1077.0     7157.0       66.5
File Read 4096 bufsize 8000 maxblocks        15382.0   141486.0       92.0
Pipe Throughput                             111814.6   175328.8       15.7
Pipe-based Context Switching                 15448.6    36831.8       23.8
Process Creation                               569.3     2142.8       37.6
Shell Scripts (8 concurrent)                    44.8      131.4       29.3
System Call Overhead                        114433.5   160565.3       14.0
                                                                 =========
     FINAL SCORE                                                      37.7

Der Test hat ne halbe ewigkeit gebraucht^^
Is aber zum vergleich was ich im 1ten thread shcon gesehen hab  SEHR wenig!

Kann mir jemand mal sagen warum ich einen ping von 600 habe wenn ich darauf einen CS:S server installiere?
Die anforderungen sind doch eigenlich erfüllt?
Mich würde es einfach mal interessieren warum das so ist^^

mfg
« Letzte Änderung: 10.Januar 2009, 15:58:48 von R. S. »
Gespeichert

R. S.

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 11
Re: Feedback Performance vServer #2
« Antwort #14 am: 10.Januar 2009, 16:19:23 »

Was mir gerade aufgefallen ist:
Die anbindung is SEHR langsam. Ich bekomme gerade mal ~280kb/s auf die reihe!
Das ist DSL 2000 niveu! MIt Mehren Servern getestet.
Und am upload vom anderen Sevrern liegts 100% net^^
Gespeichert

Bensen

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 8
Re: Feedback Performance vServer #2
« Antwort #15 am: 11.Januar 2009, 10:58:04 »

Am Anfang funktionierte noch alles wunderbar (keine Timeouts, SSH abstürzte etc.) und ich konnte sogar einen Counter Strike Source Server mit 8 Slots betreiben. Latenz lag im durchschnitt bei 30-40ms und Laggs gab es fast keine (Server lief zum testen 2 Tage).

Jetzt muss ich erstmal 10-30 Sekunden warten bis ich mich überhaupt über SSH anmelden kann und die Befehle werden auch nur in Zeitlupe wahrgenommen etc. Und in den Abendstunden stürzt der vServer auch regelmäßig ab:

The system is going down for reboot NOW!
Ohne das sich im Kundencenter einen Reboot, oder Start/Stop des Servers angefordert habe.

Am Anfang lief der Server wesentlich besser und jetzt kann man fast gar nicht mit mit ihm arbeiten.
Ich weiß natürlich das es ein Beta-Test ist und da ersteht man auch die kleinen Ausfälle etc., aber so kann man den vServer echt nicht testen.

Zudem wird bei mir seit 2009 nicht mehr der Traffic im Kundencenter angezeigt (81.89.100.156).
Gespeichert

Heiko

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 5
Re: Feedback Performance vServer #2
« Antwort #16 am: 11.Januar 2009, 11:50:51 »

Ich kann auch von solchen Problemen berichten, wenn ich im System etwas aufrufe (mc) oder installiere,
habe ich eine

load average von :2.38, 1.57, 1.38

und das System hängt ohne Ende. Und das direkt nach der Neuinstallation.

Auch beim anmelden, dauert es mitunter schon mal 20 sec. bis ich ein Login bekomme.

Abstürze wie mein Vorschreiber, konnte ich bis jetzt noch nicht feststellen.

IP: 81.89.97.159

Gespeichert

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3414
    • http://www.euserv.de
Re: Feedback Performance vServer #2
« Antwort #17 am: 11.Januar 2009, 15:36:16 »

Hallo,

danke fürs erste Feedback in der 2. Runde. Akuell habe immer noch einige Hostnodes zu viel Load und hängen teilweise ziemlich lang. Im Ergebnis ist z.B. auch ein Download langsam und es gibt Verbindungsabbrüche.

Wir arbeiten derzeit an den Skripten für bessere Loadverteilung, das dauert aber noch etwas.

viele Grüße,
Thomas
Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

Janny82

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 8
Re: Feedback Performance vServer #2
« Antwort #18 am: 12.Januar 2009, 08:26:34 »

Ist das normal, dass nur nach einem "su user" Befehl es 10 Sekunden dauert, bis dieser ausgeführt wird?
Gespeichert

Xperienc

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 56
  • Blub?
Re: Feedback Performance vServer #2
« Antwort #19 am: 12.Januar 2009, 11:36:57 »

Ist das normal, dass nur nach einem "su user" Befehl es 10 Sekunden dauert, bis dieser ausgeführt wird?

s. die Postings über dir.
Gespeichert
 

Seite erstellt in 0.657 Sekunden mit 16 Abfragen.