Forum EUserv

Allgemeine Foren => Kundenprojekte / Kundenwebsites => Thema gestartet von: SierraX am 24.Dezember 2015, 08:33:24

Titel: LFMF: OpenBSD DIY Upgrade
Beitrag von: SierraX am 24.Dezember 2015, 08:33:24
Guten Morgen,

gestern hab ich auf einem meiner Spiel und Lernserver (Miserfi S V6) erst mal das von Euserv als Dev angebotene OpenBSD 5.8 zu installieren... Hat damit nicht gebootet... nuja ist ja auch beschrieben das es schwere Fehler geben kann...
Nachdem das gescheitert ist, hab ich das als Testing markierte OpenBSD 5.6 installiert. NICHTS daran gemacht, ausser die OpenBSD 5.7 Dateien von A nach B zu kopieren (nuja die Übertragungsgeschwindigkeit war teilweise grauenhaft, obwohl es 2 Server von Euserv sind).
Egal ich habe mich an die Anleitung http://www.openbsd.org/faq/upgrade57.html#upgrade gehalten. Sollte ja kein Problem sein...
Allerdings ... ich weiss nicht an welcher Stelle es dann passiert, bzw passiert ist (weil es auf einem 2ten OpenBSD Server nachvollzogen werden konnte). Stimmte das root Passwort nicht mehr mit dem aus den Serverdaten überein und ich konnte mich somit nicht mehr einloggen.
Das Problem kann und sollte umgangen werden, in dem man eine authorized_keys mit einem seiner PublicKeys unter /root/.ssh anlegt.
Ob es auch durch kopieren der alten /etc/spwd.db geht hab ich noch nicht probiert, da aber nach Entpacken der tarballs sehr viele Funktionen nur noch eingeschränkt bis gar nicht mehr funktionieren sollte man es nicht darauf ankommen lassen wenn es sich um ein Produktiv System handelt.
Falls man es wieder aufräumen will, sollte man ein passwd root ausführen und das Passwort aus den Serverdaten neu hinterlegen. Sowie ggf die /root/.ssh/authorized_keys wieder löschen.
Und noch ein weiterer Tip: Da sudo und alles was damit zu tun hat bei OpenBSD 5.8 aus der base geflogen ist, sollte man sich wirklich als root einloggen und nicht über einen "Substitute User (sudo su -)" kommen.

Hope this helps
Kind Regards and Happy Whatever
Titel: Re: LFMF: OpenBSD DIY Upgrade
Beitrag von: Forum-Support2 am 24.Dezember 2015, 09:37:28
Hallo,

sofern Sie Probleme mit der Übertragungsgeschwindigkeit haben, prüfen Sie der Reihe nach:

* Status der Nic (sollte mindestens 100Mbit Full Duplex sein)
* Treiber für die Nic (gibt es Bugs für den Treiber / Chipsatz?)

Wenn alles passt:

* Starten Sie das Rescue-System (Linux) und prüfen Sie nochmals.

Wenn das auch nicht passt in Bezug auf die Geschwindigkeit, kontaktieren Sie bitte den Support, damit der den Switchport prüfen kann.