keine IPv4 Adresse / IPv6-Routing zu www.google.de / Ubuntu Sources IPv6

Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge
Erweiterte Suche  

Autor Thema: keine IPv4 Adresse / IPv6-Routing zu www.google.de / Ubuntu Sources IPv6  (Gelesen 268 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

derKowalski

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 4

Hallo,

vielen Dank für die Bereitstellung meines neuen Beta-vServers.  :)

Ist es richtig, dass die Server keine IPv4 Adresse haben?

Nachdem ich Ubuntu 18 installiert hatte wollte ich per "apt-get update" die aktuellen Paketlisten ziehen.
Hinterlegt ist http://de.archive.ubuntu.com, die hat keine IPv6 Adressen.
Nachdem ich die Quelle in http://archive.ubuntu.com geändert hatte klappten die Updates.
Aber ich bin mir sicher, dass es noch viele Server im Netz gibt die nur per IPv4 erreichbar sind.

LG
Achim
« Letzte Änderung: 06.Juni 2019, 14:03:35 von Forum-Support2 »
Gespeichert


Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3501
    • http://www.euserv.de
Re: keine IPv4 Adresse
« Antwort #1 am: 17.Mai 2019, 19:36:21 »

Hallo,

ja, der CBCI closed Betatest ist IPv6 only. (Wir möchten in diesem Zusammenhang die Deployments von IPv6 fördern.)
Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

system_27

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 99
    • my Gettoweb
Re: keine IPv4 Adresse
« Antwort #2 am: 18.Mai 2019, 05:09:16 »

darüber bin ich auch gestolpert. Meine Idee war dann die euserv mirror-server (ubuntu.mirror.euserv.net) zu verwenden. Aber der ist nicht signiert.


Gespeichert
meine Signatur macht Urlaub :-(

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3501
    • http://www.euserv.de
Re: keine IPv4 Adresse
« Antwort #3 am: 18.Mai 2019, 06:47:52 »

Hallo,

der CBCI betatest ist primär für Euch zum Testen der Umgebung an sich und zur Migration von der alten OpenVZ Plattform auf die neue gedacht. IPv4 funktioniert natürlich, da wir die neue Umgebung bereits selbst für einige Dienste nutzen.

Es ist geplant, den Betatest im Laufe des Jahres auf weitere Plattformen und neue Funktionen auszuweiten. Wir haben dazu eine Roadmap, nachdem wir Euer Feedback bearbeitet haben.

Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

hne

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 5
Re: keine IPv4 Adresse
« Antwort #4 am: 20.Mai 2019, 11:35:45 »

Hallo,

ja, der CBCI closed Betatest ist IPv6 only. (Wir möchten in diesem Zusammenhang die Deployments von IPv6 fördern.)

Da mir nur ein Zugang über IPv4 möglich ist, kann ich den Server leider nicht erreichen.
Davon abgesen bräuchten auch die zu testenden Dienste IPv4.
Gespeichert

razor1986

  • Grünschnabel
  • *
  • Offline Offline
  • Geschlecht: Männlich
  • Beiträge: 64
Re: keine IPv4 Adresse
« Antwort #5 am: 20.Mai 2019, 14:24:29 »

Hallo,

hne nimm doch einfach deinen bestehenden vServer als Jump Host. Damit kommst du dann drauf.
Gespeichert
Ich würde mich ja gerne geistig mit dir duellieren, aber ich sehe du bist leider unbewaffnet.

hne

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 5
Re: keine IPv4 Adresse
« Antwort #6 am: 23.Mai 2019, 10:58:44 »

Tja, die Idee hatte ich schon. Geht aus anderen Gründen nicht.

1. DNS funktioniert im Jump-Server nicht
root@jumper# host srv******-****.blue.kundencontroller.de
Host srv******-****.blue.kundencontroller.de not found: 3(NXDOMAIN)
IPv6 im Jump-Server funktioniert im Prinzip:
root@jumper# host www.google.de
www.google.de has address 216.58.207.35
www.google.de has IPv6 address 2a00:1450:4001:824::2003

2. Mit IP-Adresse funktioniert der Ping zu 33%:

root@jumper# ping6 -c 3 2a02:0180:0006:0001:0000:0000:0000:027d
PING 2a02:0180:0006:0001:0000:0000:0000:027d(2a02:180:6:1::27d) 56 data bytes
64 bytes from 2a02:180:6:1::27d: icmp_seq=3 ttl=61 time=0.276 ms

--- 2a02:0180:0006:0001:0000:0000:0000:027d ping statistics ---
3 packets transmitted, 1 received, 66% packet loss, time 1999ms
rtt min/avg/max/mdev = 0.276/0.276/0.276/0.000 ms

3. Mit SSH endlich den Jump per IPv6-Adresse geschafft.
Komme aber mit IPv6 vom neuen Server aus nicht raus:

root@srvxxxx# ping6 -c 3 www.google.de
PING www.google.de(fra16s24-in-x03.1e100.net) 56 data bytes

--- www.google.de ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

root@srvxxxx# curl -6 -v www.google.de
* Rebuilt URL to: www.google.de/
*   Trying 2a00:1450:4001:824::2003...
* connect to 2a00:1450:4001:824::2003 port 80 failed: Connection timed out
* Failed to connect to www.google.de port 80: Connection timed out
* Closing connection 0
curl: (7) Failed to connect to www.google.de port 80: Connection timed out

5. Web-Applikation benötigt zuriff von aussen, auch mit IPv4 für Rechner, die kein IPv6 können.

Fazit: Ich habe kein funktionierendes System. IPv6 only ist nur halb fertig.
Es mag eine gute Idee sei, IPv6 vorantreiben zu wollen. Aber nicht auf diese Art.

h.n.e.
Gespeichert

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3501
    • http://www.euserv.de
Re: keine IPv4 Adresse
« Antwort #7 am: 03.Juni 2019, 11:04:58 »

Hallo,

danke für Euer Feedback.

Die IPv6 Routing Problematik konnte behoben werden.

~]# mtr -r ipv6.google.com
HOST: localhost                  Loss%   Snt   Last   Avg  Best  Wrst StDev
  1. gw-ipv6-2A02-0180-1-1.as3536  0.0%    10    1.0   1.0   0.8   1.1   0.1
  2. po162.ipv6.bbsw-h3-j1cr.as35  0.0%    10    1.2   1.2   0.9   2.5   0.5
  3. po150.ipv6.bbsw-h2-j1a.as353  0.0%    10    1.0   1.0   0.8   1.2   0.1
  4. 2a02:238:1:f072::2            0.0%    10    1.8   2.1   1.7   2.7   0.3
  5. decix.hlkomm.net              0.0%    10   11.7  11.6  11.0  12.0   0.3
  6. de-cix.fra.google.com         0.0%    10   13.3  12.2  11.1  16.2   1.8
  7. 2001:4860:0:11df::1           0.0%    10   17.8  17.8  17.7  17.9   0.1
  8. 2001:4860:0:1::1aad           0.0%    10   17.4  17.4  17.1  17.5   0.1
  9. fra15s11-in-x0e.1e100.net     0.0%    10   16.8  16.8  16.8  16.9   0.0


Bzgl. der Paketverluste IPv6:

Da auf dem Server kein Datenverkehr vorhanden war, musste er NDP-seitig erstmal eine Verbindung aufbauen. Deswegen laufen 1 bis 2 pings am Anfang ins Leere. Das liegt an der Natur der Sache und ist überall so, wenn erstmalig Datenverkehr passiert. (äquivalent zu ARP bei IPv4)

Wenn man also nur 3 Pings macht, erhält man folglich 66% Loss. Ich würde 100 Pings empfehlen. Wenn der Server normale Dienste verwendet, fallen diese ersten verlorenen Pakete nicht auf, zumal es nur einmal passiert und danach u.U. nach einem Reboot.

Wir freuen uns über weiteres Feedback, insbesondere ob das Feedback aus diesem Thread jetzt läuft!


viele Grüße,
Thomas
Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

hne

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 5
Re: keine IPv4 Adresse
« Antwort #8 am: 06.Juni 2019, 11:52:26 »

Hallo Thomas,

Ping und cURL zu www.google.de funktionieren jetzt sauber.

Danke!
Gespeichert

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3501
    • http://www.euserv.de
Re: keine IPv4 Adresse / IPv6-Routing zu www.google.de
« Antwort #9 am: 06.Juni 2019, 14:03:21 »

Hallo,

die Problematik mit Ubuntu & IPv6 wurde behoben.

Nach einer erneuten Installation ist ein Upgrade möglich. Bei bestehenden Installationen können Sie das Problem mit dem Befehl:

sed -i 's/de\.archive\.ubuntu\.com/de2.archive.ubuntu.com/ig' /etc/apt/sources.list
beheben.

viele Grüße,
Thomas
Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

Tomy

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 1

Hallo,

vielen Dank für die Bereitstellung meines neuen Beta-vServers.  :)

Ist es richtig, dass die Server keine IPv4 Adresse haben?

Nachdem ich Ubuntu 18 installiert hatte wollte ich per "apt-get update" die aktuellen Paketlisten ziehen.
Hinterlegt ist http://de.archive.ubuntu.com, die hat keine IPv6 Adressen.
Nachdem ich die Quelle in http://archive.ubuntu.com geändert hatte klappten die Updates.
Aber ich bin mir sicher, dass es noch viele Server im Netz gibt die nur per IPv4 erreichbar sind.

LG
Achim

Hallo,

bei Debian besteht das selbe Problem.
Wenn man z.B. per "wget" etwas auf den vServer laden möchte, kommt folgende Meldung:
Verbindungsaufbau zu xyz.com (xyz.com)|123.456.78.910|:80 ... fehlgeschlagen: Das Netzwerk ist nicht erreichbar.
Somit ist der vServer zum ausgiebigen Testen nicht brauchbar.
Es ist zwar löblich IPv6 voran zu treiben, solange aber nicht jeder Server im Netz IPv6 voll unterstützt bzw. dafür voll konfiguriert ist, sollte immer noch IPv4 auf den vServer verfügbar sein.
Gespeichert

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3501
    • http://www.euserv.de

Hallo,

nutzen Sie am besten IPv6 enabled Hosts wie z.B.

~]# ping6 -n ftp.ipv6.debian.org
PING ftp.ipv6.debian.org(2001:67c:2564:a119::148:12) 56 data bytes
64 bytes from 2001:67c:2564:a119::148:12: icmp_seq=1 ttl=59 time=30.8 ms
64 bytes from 2001:67c:2564:a119::148:12: icmp_seq=2 ttl=59 time=30.7 ms
64 bytes from 2001:67c:2564:a119::148:12: icmp_seq=3 ttl=59 time=30.8 ms
^C
--- ftp.ipv6.debian.org ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2836ms
rtt min/avg/max/mdev = 30.727/30.781/30.818/0.206 ms

und nehmen die in die Repo-Liste auf.

Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---

gumarn

  • Grünschnabel
  • *
  • Offline Offline
  • Beiträge: 1

Hallo, das Update/Upgrade von Ubuntu bei Verwendung von http://de2.archive.ubuntu.com/ubuntu/ klappt.

Ich habe aber mal die Nutzung des EUserv Mirror-Servers versucht, wie im Wiki beschrieben (http://wiki.euserv.com/index.php/Manual_EUserv_Mirror_Server#Ubuntu).
In der Datei /etc/apt/sources.list wurden an bionic angepasste Werte verwendet.

Leider wird die connection refused:
root@srv***:/# apt-get update
Err:1 http://ubuntu.mirror.euserv.net bionic InRelease
  Could not connect to ubuntu.mirror.euserv.net:80 (2a02:180:ffff:1::551f:b966). - connect (111: Connection refused)
Gespeichert

Forum-Support2

  • EUserv Internet
  • Foren Legende
  • *
  • Offline Offline
  • Beiträge: 3501
    • http://www.euserv.de

Hallo,

danke für den Hinweis, das mit dem Mirror Server schauen wir uns an!
Gespeichert
viele Grüsse / kind regards
Thomas
EUserv Foren Support
---
 

Seite erstellt in 0.058 Sekunden mit 21 Abfragen.